08
Jan
2022

This version (1.0.5) of the Compose Compiler requires Kotlin version 1.5.31 but you appear to be using Kotlin version 1.5.21 which is not known to be compatible – Error Log

Kapan

Ketika melakukan compile proyek android yang menggunakan library compose

Penyebab

Versi kotlin tidak compatible dengan library compose versi 1.0.5

Solusi

Gunakan kotlin versi 1.5.31

Cara menggantinya, silahkan buka build.gradle project dan ganti seperti kode di bawah

buildscript {
    ...
    dependencies {
        ...
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.5.31"
    }
}
Share

You may also like...